华为交换路由配置命令大全

分享自己最近搜藏的交换路由常用配置命令,学会这些配置交换机基本没撒问题 ,我都做了相关命令的注释,欢迎各位看客指正补充 相互学习。

远程登录
    [ar1] user-interface vty 0 4                         //进远程登录配置视图
    [ar1-ui-vty0-4] authentication-mode aaa             //启用AAA认证
    [ar1-ui-vty0-4] user  privilege  level  3              //设置权限级别
    [ar1] aaa                                          //进AAA配置视图
    [ar1-aaa] local-user ntdadm password cipher Taren1     //添加用户ntdadm
    Info: Add a new user.
    [ar1-aaa] local-user ntdadm service-type telnet     //选择控制方式telnet
交换机基本命令

     <Huawei>undo terminal monitor    //取消消息提示
    <Huawei>system-view       //进入系统视图
    [Huawei]sysname sw1     //设置主机名
    [sw1]display mac-address   //显示MAC地址表
    <sw1>display bridge mac-address  //显示交换机本身的MAC地址
    [sw1]lldp enable  //显示令居发现功能
    [sw1]display lldp neighbor brief   //显示令居摘要信息
    [sw1-Ethernet0/0/1]undo nego tiation auto  //取消端口自动协商功能
    [sw1-Ethernet0/0/1] duplex full   //设置端口的双工模式
    [sw1-Ethernet0/0/1]speed 100    //设置端口的速率
    [sw1-Ethernet0/0/1]display this  //显示当前配置信息

    [swi-g0/0/0]undo shutdown     //启用端口
    [sw1]display ip interface brief   //查看端口信息摘要
    <sw1>display interface GigabitEthernet 0/0/0   //显示路由器端口的详细信息

记录所有协议和端口号的文件
C:\Windows\System32\drivers\etc\services

VLAN基本命令
     display port vlan                                        //显示端口vlan信息
     [sw1]display vlan                                     //显示valn信息
     [sw1]valn2                                              //创建一个vlan
     [sw1-vlan2]description sales                 //为vlan添加描述信息
     [sw1]vlan batch 6 8 10 12                      //批量创建多个不连续的vlan
     [sw1]vlan batch 13 to 20                       //批量创建多个连续的vlan
     [sw1]undo vlan 2                                  //删除一个vlan
     [sw1]undo vlan batch 6 8 10 12            //删除多个不连续的vlan
     [sw1]undo vlan batch 13 to 20             //删除多个连续的vlan

     [sw1]int e0/0/1
     [sw1-Ethernet0/0/1]port link-type access         //设置端口模式为access
     [sw1-Ethernet0/0/1]port default vlan 10          //把端口加入vlan

批量把端口加入vlan
     [sw1]port-group 1                                                                                            //创建端口组
     [sw1-port-group 1]group-member e0/0/2   to  e0/0/6                                    //把端口加入端口组
     [sw1-port-group 1]port link-type access                                                            //设置端口模式
     [sw1-port-group 1]port default vlan 10                                                         //把端口加入vlan10       [sw1]display port vlan                                               //显示端口vlan信息

更改端口模式asscee=>trunk
     [sw1]int e0/0/4
     [sw1-Ethernet0/0/4]display this                      //显示当前配置信息
     [sw1-Ethernet0/0/4]undo port default vlan   //还原端口的默认vlan设置
     [sw1-Ethernet0/0/4]port link-type trunk     //更改端口为trunk模式
     [sw1-Ethernet0/0/4]port trunk allow-pass vlan 10 20
     [sw1-Ethernet0/0/4]port trunk allow-pass vlan all     //允许哪些vlan的数据帧通过
     [sw1-Ethernet0/0/4]port trunk pvid vlan 10              //把trunk端口加入lvan(可不打)

hybrid模式

只要确认了端口模式,此端口处理标签是固定的,不能更改。
access模式                       发送数据帧不带标签(不能更改)
trunk模式                         发送数据帧带标签(不能更改)
hybrid                             发送数据帧可以带标签页可以不带标签

[sw1]int e0/0/1
[sw1-Ethernet0/0/1]port link-type hybrid                //更改为hyrid模式
[sw1-Ethernet0/0/1]port hybrid Pvid vlan 10          //把hybrid端口加入vlan10
[sw1-Ethernet0/0/1]port hybrid untagged vlan 10    //指定端口处理标签的动作
[sw1-Ethernet0/0/1]port hybrid tagged vlan 10       //指定端口处理标签的动作

路由基本命令
     [r1]ip route-static 192.168.3.0 24 192.168.2.2      //创建静态路由
     [r1]display ip routing-table         //显示路由表

单臂路由
[r1]int g0/0/0.1
[r1-GigabitEthernet0/0/0.1]dot1q termination vid 10    //关联vlan    
[r1-GigabitEthernet0/0/0.1]ip address 192.168.10.1 24
[r1-GigabitEthernet0/0/0.1]arp broadcast enable        //开启arp广播
[r1]int g0/0/0.2
[r1-GigabitEthernet0/0/0.2]dot1q termination vid 20    //关联vlan    
[r1-GigabitEthernet0/0/0.2]ip address 192.168.20.1 24
[r1-GigabitEthernet0/0/0.2]arp broadcast enable        //开启arp广播

设置trunk
[sw1-Ethernet0/0/1]int e0/0/3    
[sw1-Ethernet0/0/3]port link-type trunk 
[sw1-Ethernet0/0/3]port trunk allow-pass vlan all

三层交换机
设置虚拟路由接口的IP地址
[sw1]int Vlanif 10
[sw1-Vlanif10]ip address 192.168.10.1 24

STP生成树协议
<Huawei>display stp                              //显示生成树信息
<Huawei>display stp brief                     //显示生成树摘要信息
<Huawei>display bridge mac-address                   //查看MCA地址

生成树基本命令
     [Huawei]stp disable | enable                                                           //禁用,启用生成树协议
     [Huawei]stp mode       mstp        多生成树模式(默认模式)            //设置生成树模式
                                         rstp         快速生成树模式
                                         stp          普通生成树模式

[sw3]stp priority 8192 (0-61440)                      //设置网桥优先级
[sw3]stp root primary                                        //把网桥优先级设置为0
[sw3]stp root secondary                                   //把网桥优先级设置为4096
[sw3-Ethernet0/0/1]stp cost 20000                  //更改端口开销值
[sw3-Ethernet0/0/5]stp disable                       //禁用端口的生成树功能
mstp配置
[sw1]vlan batch 10 20      创建vlan
2.设置trunk端口
port-group 2
group-member e0/0/1 e0/0/2
port link-type trunk
port trunk allow-pass vlan all
3.禁用连接pc机端口的生存树协议
port-group 1
group-member e0/0/3 e0/0/4
stp disable
把端口加入vlan
int e0/0/3
port link-type access
port default vlan 10
int e0/0/4
port link-type access
port default vlan 20

1.配置生成树区域:sw1,sw2,sw3
[sw1]stp region-configuration                                  //进入区域配置
[sw1-mst-region]region-name ntd1908                   //设置区域名称
[sw1-mst-region]instance  1 vlan 10                       //创建第一条路并指定允许通过的vlan
[sw1-mst-region]instance  2 vlan 20                      //创建第二条路并指定允许通过的vlan
[sw1-mst-region]active region-configuration        //激活区域

2.为每条路指定根网桥
[sw1]stp instance 1 priority 4096                      //指定sw1为第一条路的根网桥
[sw1]stp instance 2 priority 8192                      //指定sw1为第二条路的备根
[sw2]stp instance 2 priority 4096                      //指定sw2为第二条路的根网桥 
[sw2]stp instance 1 priority 8192                      //指定sw2为第一条路的备根

DHCP相关配置:

配置全局模式的DHCP服务器
[dhcp]dhcp enable                                      //开启路由器的DHCP功能
[dhcp]ip pool p1                                         //创建赢名为P1的地址池
[dhcp-ip-pool-p1]network 192.168.10.0 mask 24             //指定网段
[dhcp-ip-pool-p1]gateway-list 192.168.10.254                 //指定网关
[dhcp-ip-pool-p1]dns-list 202.106.196.115                      //指定DNS服务器
[dhcp-ip-pool-p1]lease day 1                                          //指定租约
[dhcp-ip-pool-p1]excluded-ip-addre 192.168.10.201. 192.168.10.253          //指定排除地址
[dhcp]int g0/0/0
[dhcp-GigabitEthernet0/0/0]ip address 192.168.10.2 24
[dhcp-GigabitEthernet0/0/0]dhcp select global                //启用DHCP全局模式

配置接口模式DHCP服务器

简单快速的布置DHCP服务器,不需要创建地址池。

[r1]dhcp enable
[r1]int g0/0/0
[r1-GigabitEthernet0/0/0]ip add 192.168.1.1 24 
[r1-GigabitEthernet0/0/0]dhcp select interface              //启用接口模式
[r1-GigabitEthernet0/0/0]dhcp server dns-list 1.1.1.1       //指定DNS地址
[r1-GigabitEthernet0/0/0]dhcp server excluded-ip-addre 192.168.1.200 192.168.1.254        //指定排除地址
[r1-GigabitEthernet0/0/0]dhcp server lease day 3               //指定租约

[relay]dhcp enable                            //启用dhcp功能
[relay]int g0/0/0                                //进入客户端相连的端口
[relay-GigabitEthernet0/0/0]dhcp select relay                    //启用dhcp中继代模式    
[relay-GigabitEthernet0/0/0]dhcp relay server-ip 192.168.2.1(dhcp服务器的IP地址)             //指定要联系的dhcp服务器的地址

VRRRP协议
[sw-Vlanif20] vrrp vrid 1 virtual-ip 192.168.1.254                                    // 虚拟网关IP地址为 192.168.1.254
[sw-Vlanif20] vrrp vrid 1 priority 200                                                     // 配置 VRRP 优先级为 200 ,默认是100
[sw-Vlanif20] vrrp vrid 1 preempt-mode timer delay 20                       // 配置 VRRP 抢占延迟为 20s 
[sw-Vlanif20] vrrp vrid 1 track interface g0/0/1 reduced 100               // 配置链路跟踪 ,发送出去的 vrrp 报文的优先级,减少100

[sw2]int Vlanin 10
[sw2-Vlanif10]vrrp vrid 10 timer advertise 2            //修改VRRP通告周期
[sw2-Vlanif10]vrrp vrid 10 preempt-mode timer delay 6        //修改抢占延时为6S
[sw2-Vlanif10]vrrp vrid 10 preempt-mode disable              //关闭VRRP抢占功能
[sw2-Vlanif10]vrrp vrid 10 authentication-mode md5 HCIE     //配置VRRP认证
[sw2-Vlanif10]display vrrp        //查看VRRP参数
[sw2]display vrrp brief             //
[Huawei]display ip routing-table protocol static                      //查看静态路由表

[Huawei]ip route-static 192.168.1.0 24 192.168.20.1 preference 100              //修改浮动0路由的优先级

    
配置ACL
[R1]acl 2000                                                   // 创建基本 ACL
[R1-acl-basic-2000]rule 5 deny source 192.168.1.1 0.0.0.0  // 拒绝源为 192.168.1.1的流量
[R1]interface g0/0/0                                           // 连接 Server1 的接口
[R1-GigabitEthernet0/0/0]traffic-filter outbound acl 2000  // 调用ACL2000在端口的出去的方向
[RI]display acl all                                  //查看所有ACL

[R1-acl-adv-3000]rule 5 permit tcp source 192.168.1.1 0.0.0.0 destination 192.168.3.1 0.0.0.0 destination-port eq 80                   // 只允许源192.168.1.1 访问目标192.168.3.1 的 web 流量

[R1-acl-adv-3000]rule 10 permit ip source 192.168.1.1 0.0.0.0 destination 192.168.2.0 0.0.0.255             // 允许源 192.168.1.1 访问目标 192.168.2.0 网段的所有流量

[R1-acl-adv-3000]rule 15 deny ip source 192.168.1.1 0.0.0.0 destination any               //拒绝192.168.1.1的所有其他流量

[R1-GigabitEthernet0/0/2] 
traffic-filter inbound acl 3000                    // 接口的进入方向调用ACL3000

<sw1>dispalay vrrp                                                       //查看vrrp信息
<sw1>dispalay vrrp brief                                               //查看vrrp信息

NAT配置
[R1]display nat outbound                        //查看配置的NAT配置
[Huawei]dis nat session all                       //查看NAT转换表
[AR1]display acl all                                    //查看配置的ACL
[AR1]display nat address-group                    //查看配置的ACL地址池
[AR1-GigabitEthernet0/0/1]nat static global 200.1.1.12 inside 10.1.1.12        //配置静态NAT

动态NAT
[AR1]acl 2000                    //创建ACL
[AR1]rule 10 permit source 10.1.1.0 0.0.0.255                //匹配源地址为10.1.1.0/24网段
[AR1]nat address-group 1 200.1.1.1 200.1.1.10           //创建NAT地址池(地址池的名字为1,地址池的起始公网IP地址为200.1.1.1,结束IP为 200.1.1.10  )
[R1-GigabitEthernet0/0/1]nat outbound 2000 address-group 1 no-pat     //配置动态NAT

静态NAT
[AR1]int g0/0/1
[AR1-GigabitEthernet0/0/1]nat static global 200.1.1.12inside 10.1.1.12      //配置静态NAT(将内部地址10.1.1.12/24静态转换为200.1.1.12)
[AR1-GigabitEthernet0/0/1]nat static global 200.1.1.11 inside 10.1.1.11    //配置静态NAT(将内部地址10.1.1.11/24静态转换为200.1.1.11)

配置NAPT Easy ip(动态PAT)
[Huawei-acl-basic-2000]rule 5 permit source 10.1.1.0 0.0.0.255      // //匹配源地址为10.1.1.0/24网段
[Huawei]nat address-group 1 200.1.1.10 200.1.1.10                        //创建NAPT地址池(地址池中只有一个公网IP)
[Huawei-GigabitEthernet0/0/1] nat outbound 2000 address-group 1       //配置项NAPT

NAT Server配置(静态PAT)
[AR1-GigabitEthernet0/0/1]nat server protocol tcp global 200.1.1.11 80 inside 10.1.1.11 80               // 将内部地址10.1.1.11/24的80端口静态的转换为公网地址200.1.1.11的80端口
[AR1-GigabitEthernet0/0/1]nat server protocol tcp global 200.1.1.11 21 inside 10.1.1.12 21              // 将内部地址10.1.1.11/24的21端口静态的转换为公网地址200.1.1.12的21端口
[AR1]display nat server                             //验证NAT server配置   
[AR1]display nat address-group               //查看NAT地址池  
[AR1]display nat outbound                       //查看NAT配置
[AR1]display nat static                        //查看静态NAT配置
      

OSPF的配置
[AR1]ospf                             //启用OSPF服务
[AR1-ospf-1]area 0             //进入area 0区域    
AR1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255                     //在区域0中宣告网段
[AR1]ospf 2 router-id 1.1.1.1                               //手动指定router-id唯一标识
[AR1]int g0/0/0
[AR1-GigabitEthernet0/0/1]ospf timer hello         //修改hello计时器
[AR1-GigabitEthernet0/0/1]ospf timer dead        //修改dead计时器
[AR1-GigabitEthernet0/0/1]ospf dr-priority        //修改路由的优先级
<AR1>reset ospf process                                   //重启OSPF协议
[AR3-GigabitEthernet0/0/1]ospf cost 9              //将接口的cost配置为9(默认为1)
[AR1]display ospf peer brief                              //查看OSPF的邻接表
[AR1]display ip routing-table protocol ospf     //查看OSFP的路由表
<AR1>display ospf interface g0/0/0                //查看OSPF接口参数
[AR2]int g0/0/1                                      //确认进入的是BDR接口
[AR2-GigabitEthernet0/0/1]ospf dr-priority 110               //修改BDR的优先级,修改为110
[AR1]int g0/0/0
[AR1-GigabitEthernet0/0/0]ospf network-type p2p             //配置 R1-R2 之间的链路网络类型为“点到点”
[AR6]int g0/0/1
[AR6-GigabitEthernet0/0/1]ospf dr-priority 0                        // 配置R5 为 区域 56 的 DR,没有 BDR 

[Huawei]display ospf lsdb router 1.1.1.1                               //查看详细LSA
[Huawei]display ospf lsdb                                                    //查看LSA数据库
display ospf lsdb  network  x.x.x.x                                        // LSA的名字
[Huawei]display ospf brief                                                //查看OSPF路由器的身份

[AR1-ospf-1]area 12
[AR1-ospf-1-area-0.0.0.12]stub                                     //配置末梢区域

[Huawei]ospf 1
[Huawei-ospf-1]import-route static                                     //将路由表中的静态路由引入OSPF协议
[AR1]ospf 1
[AR1-ospf-1]default-route-advertise                        //默认路由通告
[AR1-ospf-1] default-route-advertise always            //强制一直产生默认路由
[AR1-ospf-1]default cost 200                                   //设置默认路由的开销值为200(默认为1)
[AR1-ospf-1]default type 1                                    //设置默认路由的类型为type1  (默认为2)
[AR1-ospf-1]import-route static cost 200 type 1    //将路由表中的所有静态路由引入OSPF,开销为200,类型为1
[AR2-ospf-1-area-0.0.0.12]abr-summary 10.10.0.0 255.255.0.0                //3类LSA汇总
[AR5-ospf-1]asbr-summary 10.50.0.0 255.255.0.0                                   //5类LSA汇总 

[AR5-ospf-1]area 45                                                          //虚拟链路穿过的区域
[AR5-ospf-1-area-0.0.0.45]vlink-peer 4.4.4.4                     //虚拟链路对端设备的router-ID
[AR5]display ospf vlink                                                     //查看虚拟链路信息   

[Huawei]display ospfv3 peer                         //查看OSPFv3邻居表

[Huawei]ipv6                                               //系统模式开启IPV6
[Huawei-GigabitEthernet0/0/0]ipv6 enable               //接口开启IPV6功能
[Huawei-GigabitEthernet0/0/0]ipv6 address 2001:0023::1 64              //配置IPV6地址
[Huawei-GigabitEthernet0/0/0]ospfv3 1 area 0             //接口启用OSPFv3,并宣告进入区域0    

[AR1]bgp 64512                              //配置R1启用BGP,并指定 AS 为 64512          
[AR1]peer 192.168.12.2   as-number  64512       //指定邻居的IP地址以及邻居所在的 AS 号
[AR1]display bgp peer                    //查看BGP邻居表
[AR1-bgp]peer 10.10.3.3 connect-interface LoopBack 13        //更改 R1 向 R3 发送 BGP 报文时所使用的源IP

思科相关:

1)用户模式
2)特权模式
3)全局模式
4)接口模式
switch>用户模式
switch#特权模式
Switch(config)#全局模式
Switch(config-if)#接口模式

switch> enable                         //进入特权模式
switch# configure terminal         //进入全局模式
switch(config)# interface f0/1    //进入接口f0/1
switch(config-if)# exit                //逐级返回,类似于华为quit
switch# disable //在特权模式返回用户模式
 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注